Celestica Documentation Portal

Find your product documents here

show running-config

Displays the active configuration on the device.

Syntaxshow running-config
Command ModeEXEC
ParametersNone
UsageUse this command to retrieve the active configuration.
Supported Releases1.0.0 or later
Click Commandshow running configuration all
Feature Specific Commands
  • Release 1.0.0
    • show running-config aaa

    • show running-config interface [Ethernet <if-id> | Loopback <id> | PortChannel <id> | Vlan <>]

    • show running-config ip access-list [<name>]

    • show running-config ipv6 access-list [<name>]

    • show running-config lldp

    • show running-config logging

    • show running-config mac access-list [<name>]

    • show running-config mclag

    • show running-config mirror-session

    • show running-config ntp

    • show running-config qos map {dot1p-tc [<name>] | dscp-tc [<name>] | pfc-priority-queue [<name>] | tc-dot1p [<name>] | tc-dscp [<name>] | tc-pg [<name>] | tc-queue [<name>]}

    • show running-config qos scheduler-policy

    • show running-config qos wred-profile [<profile-name>]

    • show running-config radius

    • show running-config sflow

    • show running-config snmp

    • show running-config tacacs

Example
sonic# show running-config
!
tacacs-server host 1.2.3.4 timeout 10
!
radius-server host 1.2.3.4 auth-port 1000
!
lldp enable
lldp system-description Test
lldp system-name test
lldp timer 20
no lldp tlv-select system-capabilities
!
ip access-list ip1
 seq 10 permit ip 10.1.1.1/24 10.1.1.2/24 dscp 10
!
ipv6 access-list ipv6_1
 seq 100 deny 47 100::1/64 100::2/64
!
mac access-list m1
 seq 80 deny any any 0x88cc
!
interface Vlan 40
 description vlan40
!
interface PortChannel 2
 description PortChannel2
 mtu 9100
 no shutdown
!
interface Ethernet 0
 description Eth0
 mtu 1500
 shutdown
 speed 40000
 no lldp enable
!
interface Ethernet 4
 description Ethernet4
 fec FC
 mtu 1700
 no shutdown
 speed auto
!
interface Ethernet 8
 description "Ethernet 8"
 fec none
 mtu 1500
 no shutdown
 speed auto
!
interface Ethernet 12
 mtu 9100
 no shutdown
 speed 40000
!
interface Ethernet 16
 description "ETHERNET 12"
 fec RS
 mtu 1500
 no shutdown
 speed 40000
 no lldp enable
--more--